Requerimientos del sistema

Requerimientos del sistema

Para instalar y correr Drupal, el servidor debe de tener ciertas características mínimas. La mayor parte de la empresas de alojamiento de sitios web contienen estas características. Sin embargo, algunas compañías se destacan por su apoyo a la comunidad de Drupal. Si necesitas alojar tu sitio considera seleccionar alguna de las compañías de alojamiento que soportan a nuestra comunidad.

Aclaración (aviso de exención de responsabilidad)

Los requerimientos mínimos de Drupal pueden estar sujetos a cambio debido a causas importantes. Cuando el cambio afecte a una amplia base de los usuarios de Drupal, se realizaran todos los esfuerzos para comunicar estas decisiones.

Espacio en Disco

Una instalación mínima requiere 15 MB. 60 MB se necesitan con un sitio con muchos módulos instalados y temas. Tenga en cuenta que necesitara mucho mas para la base de datos, archivos cargados por los usuarios , copias de seguridad y otros.

Servidor Web

Apache, Nginx, o Microsoft IIS
Mas detalles del servidor web

Base de datos:

Drupal 6: MySQL 4.1 o versión posterior, PostgreSQL 7.1,
Drupal 7: MySQL 5.0.15 o versión posterior con PDO, PostgreSQL 8.3 o versión mas alta con PDO, SQLite 3.3.7 o posterior

Drupal 8: MySQL 5.5.3/MariaDB 5.5.20/Percona Server 5.5.8 versión posterior con PDO y InnoDB motor de almacenamiento compatible, PostgreSQL 8.3 o posterior con PDO, SQLite 3.4.2 o mas alta.

Microsoft SQL Server and Oracle son soportados utilizando módulos adicionales.
Mas detalle sobre la base de datos.

PHP

Drupal 6: PHP 5.x solamente (5.2.5 o version posterior se recomienda ). Aviso: soporte para PHP 4.x ha sido descontinuado. El nucleo Drupal funciona con PHP 5.3.x, pero PHP 5.3.x y posteriores versiones pueden producir errores especialmente en modulos y temas desarrollados para extender la funcionalidad del nucleo.
Drupal 7: PHP 5.2.5 + (5.4 o posterior recomendado).
Drupal 8: PHP 5.5.9 o posterior

Más detalles sobre los requerimientos de PHP , incluyendo requerimientos de memoria

****************************************************************************************************************************************************************

Servidor web

Drupal es capaz de correr en cualquier servidor que soporte con PHP

Nota de seguridad: Algunas de las características de seguridad sólo se proporcionan para Apache y IIS mediante el uso de archivos .htaccess y web.config. Usted es responsable de recrear estas características cuando se utiliza un servidor web diferente.

Apache (recomendado)

Apache es el servidor web más utilizado para Drupal. Drupal trabajará en Apache 2.x y puede ser alojado en UNIX / Linux, OS X o Windows.

La mayor parte del desarrollo de Drupal y el despliegue se realiza en Apache, por lo que hay más experiencia y documentación de parte de la comunidad y la mayor parte de las pruebas son realizadas en Apache que en otros servidores web. Drupal 7 y 6 probablemente correran en Apache 1.3.

Se puede utilizar la extensión de Apache "mod_rewrite" para permitir URLs limpias. Tenga en cuenta que con Drupal 8, las urls limpias están habilitadas de forma predeterminada y no se pueden desactivar, de modo que la extensión "mod_rewrite" necesita ser instalada y habilitada para que Drupal 8 sea exitosamente instalado.

La configuración en Apache de Virtualhost debe contener la directiva "AllowOverride All" para permitir que las directrices en el archivo .htaccess puedan ser utilizadas.

Nginx

Nginx es un servidor web ampliamente utilizado que se centra en la alta concurrencia, el rendimiento y poco uso de memoria.

Drupal funcionará en versiones Nginx heredados (0.7.x, 0.8.x, 1.0.x, 1.2.x), las versiones 1.4.x estables, y las versiones 1.5.x alojados en UNIX / Linux, OS X o Windows. Nginx es una alternativa popular a Apache, por lo que también hay experiencia significativa de la comunidad y de las pruebas realizadas en Nginx.

Para obtener información sobre cómo activar las URL limpias, consulte URLs limpias con NGINX. Tenga en cuenta que con Drupal 8, urls limpias están habilitados de forma predeterminada y no se pueden desactivar. En NGINX ngx_http_rewrite_module debe estar instalado y habilitado para que Drupal 8 pueda ser exitosamente instalado y configurado.

Hiawatha

Hiawatha es un servidor web con un fuerte enfoque en la seguridad. También tiene como objetivo ser fácil de usar y ser ligero. La investigación realizada por investigadores independientes demuestra que Hiawatha ofrece un rendimiento comparable al de otros servidores web en condiciones normales , pero mucho mejor mientras está bajo ataque .

Hiawatha es totalmente compatible con Drupal. Para obtener información acerca de como reescribir y usar URL las reglas para usar Drupal con Hiawatha, lea las URL limpias con Hiawatha .

Microsoft IIS

Microsoft IIS
Microsoft IIS es un servidor web y un conjunto de módulos de extensión para ser utilizados con Microsoft Windows.

El núcleo de Drupal funciona con IIS 5, IIS 6 o IIS 7 si PHP está configurado correctamente.

Para lograr URLs limpias es posible que necesite usar un producto de terceros. Para IIS 7 se puede utilizar el módulo de reescritura de URL Microsoft o una solución de terceros.

En IIS 7 Drupal requiere Windows 2008 Server SP2 o posterior que soporte FastCGI.

PHP Built-in Web Server (Sólo para desarrollo)

PHP Built-in Web Server se incluye como una herramienta CLI SAPI en versiones de PHP 5.4.0 y superiores.

PHP Built-in Web Server fue diseñado para ayudar en el desarrollo de aplicaciones. También puede ser útil para fines de prueba o para demostraciones de aplicaciones que se ejecutan en entornos controlados. No se pretende que sea un servidor web con todas las funciones por lo tanto no debe ser utilizado como un servidor de producción para uso público.

Este servidor web se puede iniciar a través de un comando drush proporcionada por el módulo PHP server para Drupal.

****************************************************************************************************************************************************************

Base de datos

Recomendado : MySQL (o un equivalente, como MariaDB o Percona Server )

MySQL

  • Drupal 6 soporta MySQL 4.1 o superior, pero MySQL 5.0.15 o se recomienda versión superior
  • Drupal 7 soporta MySQL 5.0.15 o superior (o MySQL 1.5.30 o superior), y requiere la extensión de base de datos PDO para PHP (ver ¿Qué es PDO?).
  • Drupal 8 soporta MySQL 5.5.3 o superior con InnoDB como el motor de almacenamiento primario, y requiere la extensión de la base de datos PDO.
  • Hay varias opciones que se pueden utilizar en vez de MySQL. Drupal ha sido extensivamente probado con MariaDB, y se recomienda la versión 1.5.44 (o mayor). También es probable que utilizar Percona como servidor va a funcionar bien con Drupal, aunque no se haya probado tan extensamente.

    Notas:

  • Drupal necesita de ciertas características que pueden no estar disponibles en algunos planes de alojamiento de bajo costo, por tanto asegúrese de que su proveedor de alojamiento permita que las cuentas de base de datos cuenten con los siguientes derechos:
    SELECT, INSERT, UPDATE, DELETE, CREATE, DROP INDEX, ALTER. Estos derechos son suficientes para ejecutar Drupal 6 y 7
  • Algunos módulos, así como Drupal 5.x núcleo (pero no 6.x núcleo de Drupal), requieren, además, los siguientes derechos:
    CREATE TEMPORARY TABLES, LOCK TABLES.
  • Pueda ser necesario ajustar la variable max_allowed_packet para al menos 16M. Algunos planes de alojamiento de bajo costo establecen este valor demasiado bajo (por defecto MySQL sólo 1M). En ese caso, puede que tenga que elegir un plan de alojamiento mejor. Un valor de 1 M puede ser suficiente para Drupal 5.
  • Drupal 7 y anteriores versiones soportan tablas MyISAM y InnoDB. Drupal 8 ya no admite MyISAM como el motor de almacenamiento primaria, por lo que se recomienda tipos de tablas InnoDB. Tablas NDB (MySQL Cluster) ya no son compatibles.
  • Tenga en cuenta que si su cuenta de alojamiento web se ha creado con un panel de control gráfico como Plesk o CPanel, es muy probable que usted no tenga que preocuparse de instalar un controlador para MySQL - probablemente está ya instalado en su servidor. Es posible que usted tenga simplemente que crear su base de datos y proceder con la instalación de Drupal, puede luego volver a la documentación de Drupal si necesita alguna ayuda específica en caso de encontrar problemas.
  • PostgreSQL

    Nota: Algunos módulos que extienden Drupal pueden no soportar adecuadamente la utilización de PostgreSQL. Si está familiarizado con PostgreSQL favor enviar los problemas a los encargados de los módulos adicionales a medida que los encuentre.

    Drupal 6 soporta PostgreSQL 7.1 o superior
    Drupal 7 es compatible con PostgreSQL 8.3 o posterior

    SQLite

    SQLite 3.3.7 o superior - Drupal 7 solamente.

    Nota: Algunos módulos que extienden Drupal pueden no soportar adecuadamente la utilización de SQLite. Si está trabajando conSQLite favor enviar los problemas a los encargados de los módulos adicionales a medida que los encuentre.

    Otras bases de datos

    Microsoft SQL Server , Oracle y MongoDB son compatibles con módulos adicionales.

    Puede revisar y encontrar más detalles en el grupo empresarial , si usted está interesado en trabajar con estas base de datos.

    ****************************************************************************************************************************************************************

    Requerimientos de PHP

    A continuación encontrará algunas notas adicionales con respecto a los requisitos de PHP para Drupal. Los módulos individuales pueden tener requisitos específicos y configuraciones adicionales; por favor, comprobar la documentación del módulo también. Dentro de la interfaz de Drupal, es muy recomendable que el almacenamiento en caché este habilitada. Esto ayudará a aumentar el rendimiento de su instalación de Drupal y la experiencia del usuario final. Para más detalles vea activar caché para mejorar el rendimiento.

    En esta página:

    Fuentes de PHP

    Drupal ha sido diseñado para trabajar con PHP a como es distribuido por php.net. Se hace todo lo posible para hacer que funcione con versiones de PHP de otras fuentes, pero esto sólo se hace en base a los esfuerzos o la necesidad de la comunidad. En particular, suhosin es conocido por romper ciertas características y algunos sistemas operativos por mover componentes esenciales en otros paquetes.

    Permisos de carpetas y archivos

    Drupal y PHP deben tener permisos de lectura y escritura en el directorio /sites/default/files. Esta área se utiliza para almacenar los archivos almacenados en caché (CSS comprimido y JavaScript) y cualquier carga de archivos a través de la interfaz de Drupal. Los permisos exactos de este directorio depende de la configuración de PHP en su sistema. En términos generales, los permisos de read-write-execute ó (777) no se recomiendam por ser un riesgo de seguridad. PHP se puede ejecutar bajo la cuenta de un usuario específico en el servidor mediante suPHP en lugar de un usuario genérico (www) o nobody.

    Ajustes de Configuración de PHP

    PHP necesita los siguientes ajustes de configuración de Drupal para funcionar ( a continuación sen presentan las configuraciones que se deben de cambiar en php.ini-dist / php.ini-recommended):

    error_reporting establecer E_ALL y ~ E_NOTICE. Se está trabajando para cambiar a E_ALL para Drupal 6 y Drupal 7.
    safe_mode: off. El modo seguro puede interferir con archivos de imagen y los archivos cargados. Esto solo se aplica sólo para la versión de PHP 5.3.0 en adelante, a partir de PHP 5.4.0 Modo seguro ha sido eliminado
    Funciones Tokenizer requieren la extensión tokenizer esté habilitado. (Leer más # 357970: Función Indefinido token_get_all)

    Recomendaciones de los ajustes

    Configuración: session.cache_limiter = nocache
    Configuración: session.auto_start = 0

    Configuración: expose_php = off
    Configuración: Muestra la versión de PHP en todas las peticiones header, ver la explicacion aquí.
    Ejemplo: X-Powered-By: PHP/5.3.8

    Configuración: allow_url_fopen = off
    Nota: se recomienda por problemas de seguridad en off

    Configuración: magic_quotes_gpc = off
    Nota: Fuerzas comillas en las variables - Esta característica ha quedado en desuso a partir de PHP 5.3.0 y se retira a partir de PHP 5.4.0.

    Configuración: register_globals = off
    Noata: Problema de seguridad - Tener habilitado esta opción permite a las variables de PHP tomar valores de cualquier fuente. Esta característica ha quedado en desuso a partir de PHP 5.3.0 y se retira a partir de PHP 5.4.0.

    Configuración: display_errors = Off
    Nota: Oculta los errores (sitio web) y los enviaa al archivo de registro en su lugar.

    Requerimientos de memoria

    Los requisitos de memoria de PHP pueden variar en función de los módulos habilitadoes en el sitio.

    El núcleo de Drupal 6 requiere de tenear menos 16 MB memory_limit de PHP
    El núcleo Drupal 7 requiere 32MB.
    el núcleo Drupal 8 requiere 64MB.
    Tenga en cuenta que Drupal 8 utiliza lazy loading para la carga dee código y datos. Las pequeñas diferencias de una página pueden producir grandes diferencias en el uso de memoria. Compruebe el uso de memoria para cada tipo de página y vista. Las páginas de administración deben producir los peores casos.

    Los mensajes de advertencia se mostrará si la configuración PHP no cumple con estos requisitos. Sin embargo, mientras que estos valores pueden ser suficientes para una instalación predeterminada Drupal, un sitio de producción con un número de módulos habilitados podría requerir más memoria. Típicamente 128 MB o 256 MB se encuentran en los sistemas de producción. Algunas instalaciones pueden requerir mucho más, sobre todo con las implementaciones multimedia. Si está utilizando un servicio de alojamiento es importante comprobar con su proveedor se servicio si puede proporcionar memoria suficiente para el conjunto de módulos va a implementar o que pueden ser desplegados en el futuro. (Vea la página de aumento de límite de memoria PHP y la solución de problemas frecuentes para obtener más información sobre cómo modificar el límite de memoria de PHP.)

    Extensiones

    Extensiones de la base de datos

    La extensión de PHP para conectarse a su base de datos elegida debe estar instalada y activada. Los Conectores de base de datos soportadas actualmente de Drupal son: mysql (la extensión original de MySQL), mysqli (un conector mejorado para nuevas instalaciones de MySQL), y pgsql (para PostgreSQL). Nota: PHP 5.x ya no permite la extensión mysql de forma predeterminada. Por favor, lea los enlaces de arriba para instalar su conector correspondiente. Además, Drupal 6.x no proporciona la opción de seleccionar el conector mysql si mysqli está habilitado en la configuración de PHP.

    Extensión XML

    Extensión PHP XML (para el Blog del API, módulos de Drupal, y ping). Esta extensión está activada por defecto en la instalación estándar de PHP; la versión para Windows de PHP tiene soporte incorporado para esta extensión. La activación de la extensión XML también habilita PHP DOM. DOM es ahora un requisito del sistema.

    Librerías para imagénes

    Drupal requiere una libreria de imágenes para PHP, como la librería GD para manipular imágenes (cambiar el tamaño de las imágenes de los usuarios, módulos de imagen e imagecache). GD se incluye con PHP 4.3 y superior; por lo general se encuentra activado por defecto. GD es una extensión requerida en Drupal 7 y versiones posteriores. ImageMagick también se admite para la manipulación de imágenes básicas en el núcleo de Drupal, pero hay menos apoyo de otros módulos que extienden Drupal.

    Si tiene derechos de administrador en un servidor Debian / Ubuntu, y GD no está disponible (ver tu phpinfo ) por lo general se puede instalar ejecutando el siguiente comando:

    sudo apt-get install php5-gd

    o en RedHat / CentOS:

    sudo yum install php-gd

    Ver la ImageMagick instalar las instrucciones para su plataforma.

    JSON

    Drupal 7 y 8 requieren PHP compilado con JSON. El soporte a JSON normalmente se compila como parte del núcleo de PHP, pero en caso de que usted está recibiendo errores de PHP como Fatal error: Call to undefined function json_encode Drupal\\Component\\Serialization\\json_encode() in ... core/lib/Drupal/Component/Serialization/Json.php trate de añadir la extensión JSON.

    APC

    Las versiones recientes de APC (aparentemente desde 3.1.6) se encuentra configurado por defecto la 'depuración interna de APC" . Esto genera una gran cantidad de mensajes de PHP que pueden hacer el diagnóstico de otros problemas difíciles. Esta opción se puede desactivar durante la instalación mediante la introducción "no" a la solicitud en el prompt - si pulsa 'enter' permitirá la opción.

    También vea Drupal 7 información específica relativa a APC.

    Extensión ssh

    La extensión PECL ssh es un add-on opcional en la configuración de PHP. Si bien no es necesaria para la función normal de Drupal, cuando está ausente, tanto al añadir nuevo módulo y añadir nuevos temas en la administración de su drupal fallarán con un mensaje poco informativo: "El servidor no admite la instalación de módulos y temas de esta interfaz."

    Extensión Twig C

    Drupal 8 ahora utiliza Twig como el motor de plantillas PHP por defecto. Twig se incluye como parte del núcleo de Drupal, aunque también, opcionalmente porciones pueden ser compilados e incluidos como una extensión de PHP para mejorar el rendimiento de la rendirización de las plantillas. El reporte del estado del sitio tiene una sección que indicará si la extensión Twig se ha cargado. El código fuente de la extensión de Twig C se puede encontrar en su instalación dentro de [root drupal] [drupal root]/core/vendor/twig/twig/ext/twig. Si desea instalar la extensión, siga estas instrucciones .

    Otros

    Configuración .htaccess

    Algunos de los ajustes de la memoria están contenidos en el archivo .htaccess por defecto que se incluye con Drupal, por lo que no es necesario setearlos. Hay que tener en cuenta, sin embargo, que las opciones de configuración de PHP desde .htaccess sólo funciona bajo las siguientes condiciones:

    Con Apache (o un servidor web compatible)
    Si el archivo .htaccess se puede leer, es decir si AllowOverride All en la configuración principal de Apache (generalmente httpd.conf) está activado.
    Si PHP está instalado como un módulo de Apache
    En algunos entornos de alojamiento compartido, el acceso a estos parámetros está restringido. Si no puede realizar estos cambios usted mismo, por favor consulte a su proveedor de alojamiento para que puedan ser ajustados.

    Otras interfaces

    Revisar el manual de PHP para aprender cómo cambiar los ajustes de configuración para otras interfaces con PHP.

    xdebug

    Configuración: xdebug.show_exception_trace = 0
    Motivo: El instalador de drupal podria colisionar.

    Si se utiliza xdebug con Drupal 8:

    Configuración: xdebug.collect_params = ?
    Motivo: si se configura a un valor muy alto evitará que Drupal 8 se instale y funcione correctamente

    Configuración: xdebug.max_nesting_level = 256
    Motivo: utilizar el max_nesting_level por defecto de 100 (en versiones Xdebug <2.3) hace que algunas páginas no funcionen correctamente.

    Notas: sobre los requisitos de PHP para Drupal

    Todas las versiones

    Vea la página de phpinfo () en Drupal.org para aprender cómo utilizar phpinfo y obtener los detalles de su sistema. Por ejemplo, phpinfo informará si tiene una base de datos ya instalada y qué versiones de PHP, MySQL, etc. su sistema estan corriendo. Phpinfo también le dirá qué opciones de PHP están configuradas, así como otra información de utilidad.

    Es posible actualizar a una nueva versión de PHP que se incluye con la distribución de Linux instalada. Para RHEL, recomendamos http://iuscommunity.org/Repos y para Debian, http://www.dotdeb.org/.

    En Debian libapache2-mod-php5filter puede quedar instalado en vez de libapache2-mod-php5 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709027). Desafortunadamente el paquete libapache2-mod-php5filter contiene un error que rompe Drupal (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709023). Por lo tanto, asegúrese de especificar para utilizar el paquete-libapache2 mod-php5 en su lugar.

    Drupal 8

    Drupal 8 requiere como mínimo la versión de PHP 5.5.9 o posteriores, con la extensión CURL activada. Sin embargo, se recomienda utilizar 5.6.5 o superior. PHP 5.6 es la última versión menor de PHP, por lo que ofrece un rendimiento y mayor seguridad. Desde 5.6.5 (y 5.5.21) PHP proporciona una función de protección contra inyecciones de SQL para bases de datos MySQL. PHP 7 es la mejor elección, una vez liberado, por su mejoras en el rendimiento.

    Si su biblioteca curl es la versión 7.35 (por defecto en algunas distribuciones Ubuntu), hay un error que podría afectar de forma intermitente la conectividad con otros sitios.

    Drupal 8 no puede ser instalado en hosts con la 'magic_quotes_gpc', 'magic_quotes_runtime', o 'safe_mode' en la configuración PHP que esten activados; estos valores están en desuso en PHP 5.3 y no tienen efecto ya en PHP 5.4 o superior.

    PHP Data Objects (PDO) debe activarse para que Drupal 8 pueda instalarse y funcionar correctamente. En php.ini. Descomente (quite el punto y coma que lleva) en las líneas extension=php_pdo.dll, extension=php_pdo_mysql.dll . En Linux, estos serían extension=pdo.so and extension=pdo_mysql.so. Algunas distribuciones de Linux pueden tener estas extensiones por defecto en los archivos que se encuentran en la carpeta conf.d (Ubuntu 12.04: /etc/php5/conf.d tiene pdo.ini y pdo_mysq.ini). Si estas líneas no están allí, tendrá que agregarlas manualmente. La versión PECL de PDO no es compatible con Drupal 8 y no se puede utilizar.

    El Administrador de actualizaciones de Drupal 8 puede instalar/actualizar módulos y temas a través de SSH si las bibliotecas necesarias se han instalado en el servidor. Si tiene derechos de administrador en un servidor Debian / Ubuntu, y SSH no está disponible (ver phpinfo ) por lo general se puede instalar ejecutando:
    apt-get install libssh2-php.
    Drupal 8 puede requerir el parámetro de tiempo (max_execution_time) que este como mínimo seteado a 30 segundos.
    Si se utiliza la memoria caché opcode APC con Drupal 8, este requiere como mínimo APC 3.1.13 o superior. PHP 5.5 tiene el caché Zend opcode incorporado. Se necesita también php5-ctype.

    La siguiente es la lista de requisitos de PHP para Drupal 8 beta 12:

    <?php  $required_extensions = array(    'date',    'dom',    'filter',    'gd',    'hash',    'json',    'pcre',    'pdo',    'session',    'SimpleXML',    'SPL',    'tokenizer',    'xml',  );?>

    Drupal 7

    Drupal 7 requiere tener instalado PHP 5.2.5+ (o PHP 5.2.4, o con parches de seguridad , como la versión incluida en Ubuntu 8.04). Se recomienda PHP 5.4 o superior.

    PHP Data Objects (PDO) debe estar activada para que Drupal 7 pueda instalarse y ejecutarse correctamente. Busque en su php.ini. Descomente (quite el punto y coma que lleva) en la la línea xtension=php_pdo.dll, extension=php_pdo_mysql.dll . En las distribuciones de Linux, estas serían extension=pdo.so y extension=pdo.so y extension=pdo_mysql.so . Algunas distribuciones de Linux podrian tener por defecto estas extensiones en la carpeta conf.d ( (Ubuntu 12.04: /etc/php5/conf.d tiene pdo.ini y pdo_mysql.ini ). Si estas líneas no se encuentran, entonces deberán ser agregadas. La versión PECL de PDO no es compatible con Drupal 7 y no puede ser utilizada.

    El Administrador de actualizaciones de Drupal 7 puede instalar y actualizar módulos /temas a través de SSH si las librerias necesarias se han instalado en el servidor. Si tiene derechos de administrador en el servidor de Debian / Ubuntu, y SSH no está disponible (ver tu phpinfo ) Por lo general, se puede instalar ejecutando:

    apt-get install php-libssh2

    Las guías de instalación de APC recomiendan en ocasiones habilitar la configuración apc.include_once_override = 1. Aunque esta opción no parece afectar Drupal 6, Drupal 7 provoca que falle (pantalla blanca, error 500) No habilite para Drupal 7 reportado en apc.include_once_override .

    Las siguentes extensiones son requeridas para Drupal 7
    <?php  $required_extensions = array(    'date',    'dom',    'filter',    'gd',    'hash',    'json',    'pcre',    'pdo',    'session',    'SimpleXML',    'SPL',    'xml',  );?>

    Drupal 6
    Drupal 6 fue soportado originalmente para PHP 4.4+; sin embargo, se anunció el abandono del soporte PHP 4.x por completo el 1 de marzo de 2014.
    Aunque PHP 5.3, 5.4 y 5.5 son compatibles con Drupal 6, algunos módulos secundarios pueden no ser compatibles con PHP 5.3 y superior (por ejemplo, muchos tendran errores E_STRICT).

    Comentarios

    Enviado por carlosb el

    muy buen post

    Enviado por Golanit el

    hola, apenas estoy comenzando en drupal... quiza este no es el mejor sitio para hacer la pregunta, pero quisiera saber si no existe algun sistema drupal que incorpore todo lo que se necesita para instalarlo de forma local... algo asi como un "Drupal Server"?? Gracias!

    Enviado por hankjmatt el

    quiza este no es el mejor sitio para hacer la pregunta, pero quisiera saber si no existe algun sistema drupal que incorpore todo lo que se necesita para instalarlo de forma local.
    tower defense

    Enviado por joaquinls el

    Hola, Jairo, seria bueno que para los nuevo en esto exista un paso a paso, de como montarlo localmente y como montarlo en un server, de tal manera que enamore a el uso de esta herramienta.

    Enviado por dcastani el

    Las instrucciones de instalacion son demasiado precarias, con ellas una persona no experta, de conocimientos promedio, jamas instalara Drupal y tendra que migrar a otra parte. Ustedes tienen que hacer un gran esfuerzo por lograr claridad matematica. Apoyo el paso a paso resolviendo las preguntas basicas de donde?, cuando? y como?.

    Enviado por David123 el

    Quiza este no es el mejor sitio para hacer la pregunta, pero quisiera saber si no existe algun sistema drupal que incorpore todo lo que se necesita para instalarlo de forma local...

    Enviado por francop el

    e instalo drupal y con xamp e intente entrar por localhost y me salio error q no avia encontrar el archivo destino , me sale esto y cree una carpeta en windows xamp ( drupal)

    ¡Objeto no encontrado!

    El enlace requerido no ha sido localizado en este servidor. Si usted proporcionó el enlace de manera manual le solicitamos que por favor revise los datos e intentelo de nuevo.

    Por favor contacte con el webmaster en caso de que usted crea que existe un error en el servidor.
    Error 404
    localhost
    11-04-2010 16:39:29
    Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1

    eso es lo que sale deveria salir unos archivos para verificar que esta funcionand correctamente no cierto.